STK/PRO Tutorial
This document and the software described in it are the proprietary and trade-secret information of Analytical Graphics, Incorporated. They are provided under, and are subject to, the terms and conditions of a written software license agreement between Analytical Graphics, Incorporated and its customer, and may not be transferred, disclosed or otherwise provided to third parties, unless otherwise permitted by that agreement. Use, reproduction or publication of any portion of this material without the prior written authorization of Analytical Graphics, Incorporated is prohibited.

While reasonable efforts have been taken in the preparation of this manual to ensure accuracy, Analytical Graphics, Incorporated assumes no liability resulting from any errors or omissions in this manual, or from the use of the information contained herein.

Copyright © 2005 Analytical Graphics, Incorporated.

All Rights Reserved.

The Analytical Graphics, Incorporated name and triangle logo design are registered trademarks, Reg. U.S. Pat. & Tm. Off.


Analytical Graphics, Incorporated

Restricted Rights Notice (US Government Users excluding DoD). Notwithstanding any other lease or license agreement that may pertain to or accompany the delivery of this computer software, the rights of the Government regarding its use, reproduction and disclosure are set forth in the Commercial Computer Software Restricted Rights clause at FAR 52.227-19(c)(2).
# STK/Pro Tutorial

## CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>CREATING THE PROTUTORIAL SCENARIO</td>
<td>4</td>
</tr>
<tr>
<td>SETTING THE PROTUTORIAL ENVIRONMENT</td>
<td>5</td>
</tr>
<tr>
<td>Setting Application Properties</td>
<td>5</td>
</tr>
<tr>
<td>Setting Scenario Properties</td>
<td>6</td>
</tr>
<tr>
<td>Setting 2D Graphics Properties</td>
<td>9</td>
</tr>
<tr>
<td>SAVING THE SCENARIO</td>
<td>12</td>
</tr>
<tr>
<td>CREATING FACILITIES</td>
<td>12</td>
</tr>
<tr>
<td>Defining Facilities</td>
<td>13</td>
</tr>
<tr>
<td>The Facility Database</td>
<td>14</td>
</tr>
<tr>
<td>Setting 2D Graphics Attributes</td>
<td>16</td>
</tr>
<tr>
<td>CREATING A TARGET</td>
<td>17</td>
</tr>
<tr>
<td>CREATING A SHIP</td>
<td>18</td>
</tr>
<tr>
<td>CREATING SATELLITES</td>
<td>20</td>
</tr>
<tr>
<td>Using the Orbit Wizard</td>
<td>21</td>
</tr>
<tr>
<td>Using the Satellite Database</td>
<td>22</td>
</tr>
<tr>
<td>Defining Orbital Parameters</td>
<td>24</td>
</tr>
<tr>
<td>2D Graphics Properties</td>
<td>28</td>
</tr>
<tr>
<td>MAP PROJECTIONS</td>
<td>30</td>
</tr>
<tr>
<td>Creating a New 2D Graphics View</td>
<td>30</td>
</tr>
<tr>
<td>Sampling Map Projections</td>
<td>32</td>
</tr>
<tr>
<td>ADDING AN AREA TARGET</td>
<td>33</td>
</tr>
<tr>
<td>CALCULATING ACCESS</td>
<td>35</td>
</tr>
<tr>
<td>WORKING WITH SENSORS</td>
<td>37</td>
</tr>
<tr>
<td>Defining and Pointing Sensors</td>
<td>37</td>
</tr>
<tr>
<td>Limiting a Sensor's Visibility</td>
<td>41</td>
</tr>
<tr>
<td>MORE SATELLITE 2D GRAPHICS</td>
<td>44</td>
</tr>
<tr>
<td>Custom Display Intervals</td>
<td>44</td>
</tr>
<tr>
<td>Access Display Intervals</td>
<td>47</td>
</tr>
<tr>
<td>STATIC &amp; DYNAMIC DISPLAY OF DATA</td>
<td>50</td>
</tr>
<tr>
<td>Reports &amp; Graphs</td>
<td>50</td>
</tr>
<tr>
<td>Dynamic Displays &amp; Strip Charts</td>
<td>52</td>
</tr>
<tr>
<td>SETTING CONSTRAINTS</td>
<td>55</td>
</tr>
<tr>
<td>CREATING A WALKER CONSTELLATION</td>
<td>59</td>
</tr>
<tr>
<td>CONCLUSION</td>
<td>60</td>
</tr>
</tbody>
</table>
OVERVIEW

This tutorial presents exercises that will assist you in developing a solid understanding of the basic functions in STK as well as a brief introduction to some of STK’s more advanced features and functions. The tutorial is intended to help you develop a context in which to place the fine details of STK as you begin to work with the program and its modules. Use the demo scenarios shipped with STK and the tutorial that follows to become familiar with the basic structure of STK as well as its functions and features.

STK/Professional features are closely integrated into the exercises in this tutorial. If you do not have STK/Pro, you can only perform some of the exercises in this manual.

Although this tutorial introduces the user to many of the features available in STK, it addresses only a small sampling of STK functionality. For a complete explanation of all STK functions, please consult the STK Online Help system.

Creating the ProTutorial Scenario

The scenario is the highest-level object in STK; it includes one or more 2D Graphics windows and contains all other STK objects (e.g., satellites, facilities, etc.). This section of the tutorial guides you through the process of creating and populating a scenario.

1. Start STK; make certain that the STK workspace includes an Object Browser and at least the following toolbars: Default, 2D Graphics Properties, and Animation.

2. To create a new scenario, click the (New) icon in the toolbar. A 2D Graphics window appears. (If you are licensed for STK/Advanced VO, a 3D Graphics window also appears.)
For publication purposes, 2D Graphics colors have been reversed. In most instances, the 2D Graphics window is a color-on-black display.

To change the size of the 2D Graphics window, click and hold the mouse button on any of the corners and drag the window border. When you release the mouse button, the window re-sizes. The aspect ratio of the map projection is preserved automatically by STK, by creating blank space in the window when its size does not fit the correct ratio. Click the $\frac{2}{1}$ (2:1 Aspect Ratio) button on the toolbar to resize the window to eliminate this blank space.

A scenario icon appears in the Object Browser, along with a default name for the scenario (such as Scenario1). Rename the scenario ProTutorial. The Object Browser is updated to reflect the new name.

To rename an STK object, select it in the Object Browser, right-click the mouse and select Rename from the popup menu. Type in the new name and press the return key.

You are now ready to start building a scenario.

### Setting the ProTutorial Environment

Before performing any tasks in STK, you need to set parameters that will affect all aspects of your scenario as it is built.

### Setting Application Properties

First, we will set some application parameters for STK. These high-level parameters affect every object within the application, regardless of the scenario currently open.
1. To set parameters for the STK application, select Options... from the **Tools** menu.

2. In the window that appears, select the **Save/Load Prefs** tab:

3. In the **Ephemeris** frame, verify that Save Vehicle Ephemeris is enabled and Binary Format is disabled.

4. Verify that Save Accesses is disabled.

5. Verify that Auto Save is enabled, and that the Directory field is populated with the location where you want to save STK files. Also verify that Save Period is set to 5 min (300 sec).

6. Click OK to apply any changes and to dismiss the Options window.

**Setting Scenario Properties**

You will now set some units of measurement to be used throughout the scenario and also set 2D graphics so that objects in the 2D Graphics window can easily be seen.

1. Highlight the scenario in the Object Browser, and click the ![Properties](Properties) button on the toolbar to display its **Properties Browser**.
2. On the **Time Period** page, change the scenario’s Start time and Epoch to 1 Jul 2002 00:00:00.00 and its Stop time to 1 Jul 2002 04:00:00.00. Open the **Animation** page.

3. To ensure that the 2D Graphics window is set to the correct time period, make sure the Start Time on the **Animation** page is set to 1 Jul 2002 00:00:00.00. Now open the **Units** page.
4. Verify that the settings on the Units page match the settings listed in the following table. To change a setting, double-click the unit in the CurrentUnit column, and then select the desired unit from the drop-down list.

Table 1. ProTutorial unit settings

<table>
<thead>
<tr>
<th>Field</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance Unit</td>
<td>Kilometers (km)</td>
</tr>
<tr>
<td>Time Unit</td>
<td>Seconds (sec)</td>
</tr>
<tr>
<td>Date Format</td>
<td>Gregorian UTC</td>
</tr>
<tr>
<td>Angle Unit</td>
<td>Degrees (deg)</td>
</tr>
<tr>
<td>Mass Unit</td>
<td>Kilograms (kg)</td>
</tr>
<tr>
<td>Power Unit</td>
<td>dBW</td>
</tr>
<tr>
<td>Frequency Unit</td>
<td>GigaHertz (GHz)</td>
</tr>
<tr>
<td>SmallDistanceUnit</td>
<td>Meters (m)</td>
</tr>
<tr>
<td>Latitude Unit</td>
<td>Degrees (deg)</td>
</tr>
<tr>
<td>Longitude Unit</td>
<td>Degrees (deg)</td>
</tr>
<tr>
<td>Duration Unit</td>
<td>Hours:Minutes:Seconds (HMS)</td>
</tr>
<tr>
<td>Temperature</td>
<td>Kelvin (K)</td>
</tr>
<tr>
<td>SmallTimeUnit</td>
<td>Seconds (sec)</td>
</tr>
<tr>
<td>Ratio Unit</td>
<td>Decibels (dB)</td>
</tr>
<tr>
<td>Rate Unit</td>
<td>Decibels (dB/Hz)</td>
</tr>
<tr>
<td>DopplerVelocityUnit</td>
<td>Meters per Second (m/s)</td>
</tr>
</tbody>
</table>

5. When you finish, click OK.
Setting 2D Graphics Properties

The parameters specified in the 2D Graphics properties window control the display of data and the functions available in the 2D Graphics window.

1. To set the graphics properties for the 2D Graphics window, make sure it is selected (e.g. by clicking on it), and then click the (Properties) button on the tool bar to open the 2D Graphics properties window.

2. Select Overlays. In the Animation Time frame, turn on the Show option, set X to 20 and Y to –20, and select a Text Color that will show up well on a black background.

3. Make certain the Background option is turned off.

4. Open the Details page.
5. In the Items frame, highlight RWDB2_Coastlines and RWDB2_Islands. Make sure that no other option is highlighted in this list.

6. Turn off the Show option for Lat/Lon lines.

7. In the Background frame, turn off the Image and Cloud File options, and set the Color to black.

8. Open the Projection page.

9. In the Projection Format frame, verify that the Type is set to Equidistant Cylindrical.

10. Set Center Lon to 0 deg.
11. Open the **Map Annotations** page and click the Add button.

12. Type a short phrase in the String field.

13. In the Position field, select X, Y. Enter -160 as the X coordinate and -60 as the Y coordinate.

14. Set the display Color to a color that will show up well on a black background.

15. When everything is set, click the OK button.

16. Click OK to dismiss the **2D Graphics** properties window, and then click the (Reset) button on the Animation toolbar. The 2D Graphics window should now appear similar to the one shown below. The 2D Graphics window is updated to reflect the changes you made to scenario parameters and 2D graphics.
Note
For the remainder of this tutorial, the 2D Graphics window will be shown without the text annotation and time display.

Saving the Scenario

Before proceeding to the next section, save the ProTutorial scenario.

Select Save from the File menu or click the (Save) button. This saves the scenario and all the objects you created and defined for the scenario, including the properties that you entered or selected.

Tip
You might want to select Save as... instead and create a new folder in which to store the scenario objects. It is a good idea to save the scenario frequently as you proceed through the following exercises.

Creating Facilities

Now you are ready to populate the scenario with various objects. Start with facilities such as ground stations, launch sites and tracking stations.

1. Insert a facility ( ) from the Object Catalog. Change the facility’s name to Baikonur.

2. Right-click the facility in the Object Browser and select Properties Browser from the popup menu.
Defining Facilities

1. On the Position page, verify that the Type is set to Geodetic.
2. Set Latitude to 48.0 and Longitude to 55.0. Leave Altitude at its default setting of 0.
3. Open the Description page.
4. Enter a Short Description, such as "Launch Site."
5. Enter a Long Description, such as "Launch site in Kazakhstan. Also known as Tyuratam."
6. Click OK.
7. Use the procedures described above to add the facilities listed in the following table (Don't worry about the Long Description).

Table 2. Settings for Perth & Wallops facilities

<table>
<thead>
<tr>
<th>Name</th>
<th>Latitude</th>
<th>Longitude</th>
<th>Altitude</th>
<th>Short Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Perth</td>
<td>-31.0</td>
<td>116.0</td>
<td>0.0</td>
<td>Australian Tracking Station</td>
</tr>
<tr>
<td>Wallops</td>
<td>37.8602</td>
<td>-75.5095</td>
<td>-0.012787</td>
<td>NASA Launch Site/Tracking Station</td>
</tr>
</tbody>
</table>

8. When you finish defining each facility, click OK.

The Facility Database

Now you will use the Facility Database to add two more facilities to the scenario.

1. Select Facility From Database from the Insert menu.
2. Turn on the Network option and select NASA DSN as the Network.

3. Now click Perform Search....
4. Scroll to the bottom of the list in the Facility Database Search Results window and highlight Santiago and White Sands. (Select one of them, then hold down the CTRL key and click on the other.)

5. Make sure the Creation Class is set to Facility and click OK.

6. In the Facility Database window, click Close.

7. Open the Basic Properties window for the Santiago facility and select Description.

8. Note that the Long Description field includes position and other data about the facility.

9. Click OK or Cancel.

Setting 2D Graphics Attributes

A variety of 2D graphics properties can be set for a facility in STK.

1. Select a facility whose color you would like to change—e.g. because it does not show up clearly against the background.

2. Open the facility’s 2D Graphics Attributes page, select the desired color, and click OK.
3. Repeat steps 1-2 for any other facilities whose color you wish to change.

Creating a Target

The target for this exercise is a glacier field over North America.

1. Insert a target ( ) from the Object Catalog.

2. Change the target’s name to Iceberg.

3. Open the target’s Properties Browser.

4. On the Position page, verify that the Type is set to “Geodetic”.

5. Enter a Latitude of 74.91 and a Longitude of -74.5.
6. Open the Description page and enter a short description, such as "Only the tip."

7. Click OK.

Creating a Ship

STK objects include three types of great arc vehicles—aircraft, ships and ground vehicles. In this exercise you will create a ship.

1. Insert a ship ( ) from the Object Catalog, and change its name to Cruise.

2. Open the ship’s Properties Browser.

3. On the Route page, make sure the Start Time is set to 1 Jul 2002 00:00:00:00, the Propagator is set to GreatArc, and the Smooth Rate option is selected.

---

Note

Once you enter a Rate and Start Time for a great arc vehicle, STK automatically calculates the Stop Time and displays it in a read-only field.
4. Enter the waypoint values shown in the following table for the Cruise ship in the waypoints table. To insert a line of data, click the Insert Point button.

<table>
<thead>
<tr>
<th>Latitude</th>
<th>Longitude</th>
<th>Altitude</th>
<th>Speed</th>
<th>Turn Radius</th>
</tr>
</thead>
<tbody>
<tr>
<td>44.1</td>
<td>-8.5</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
<tr>
<td>51.0</td>
<td>-26.6</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
<tr>
<td>52.1</td>
<td>-40.1</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
<tr>
<td>60.2</td>
<td>-55.0</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
<tr>
<td>68.2</td>
<td>-65.0</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
<tr>
<td>72.5</td>
<td>-70.1</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
<tr>
<td>74.9</td>
<td>-74.5</td>
<td>0.0</td>
<td>.015</td>
<td>0.0</td>
</tr>
</tbody>
</table>

5. Open the **Attitude** page, and make sure that ECF velocity alignment with nadir constraint is showing in the attitude Type selection field.

6. Open the **2D Graphics Route** page.
7. Make certain that Show Turn Markers is turned on, and click OK.

8. In the Animation toolbar, click the 🔄 (Reset) button, and look at the 2D Graphics window.

Creating Satellites

Now you will add a few satellites to the scenario, namely an Earth Resources Satellite (ERS1), a Space Shuttle and two Tracking & Data Relay (TDRS) satellites.
Using the Orbit Wizard

The STK *Orbit Wizard* provides a quick and easy way to generate a variety of frequently used satellite orbit patterns.

1. Insert a satellite ( ) from the Object Catalog. If the Orbit Wizard does not automatically appear, right-click on the satellite in the Object Browser, select Satellite Tools from the popup menu, and then select Orbit Wizard from the pull-right menu:

2. Click Next. In the second screen of the *Orbit Wizard*, select Geostationary from the dropdown list, and click Next again, bringing up the third screen.

3. In the third screen of the wizard, make sure the Subsatellite Longitude is set to \(-100\) deg, and then click Next to display the last screen of the wizard.
4. Make sure that the Orbit Start and Orbit Stop times are set to 1 Jul 2002 00:00:00.00 and 1 Jul 2002 04:00:00.00, respectively, and click Finish.

5. Change the satellite’s name to TDRS.

Using the Satellite Database

STK is shipped with a rich and extensive set of satellite databases, together with an interface to make it easy to find and propagate the satellite of interest. Here you will use the Satellite Database to define a second TDRS satellite for your scenario.

1. Select Satellite From Database from the Insert menu.
2. To quickly generate a list of all TDRS satellites in the database, do a common name search using an asterisk (*) as a wild card. Select the Common Name field and type TDRS* in the text field.

3. Click Perform Search… A Satellite Database Search Results window displays.
4. In the search results window, select TDRS C and click OK.

5. Click Close in the **Satellite Database** window.

6. Open the **Properties Browser** for the TDRS_C satellite.

7. On the **Orbit** page, make certain that **Start Time** is set to 1 Jul 2002 00:00:00.00, **Stop Time** is set to 1 Jul 2002 04:00:00.00, and **Step Size** is set to 60 seconds.

8. Click OK. If the 2D Graphics window does not show your new TDRS satellites, click the (Reset) button.

---

**Note**

*The ground tracks for both satellites display in the 2D Graphics window as specks since they are in geostationary orbit.*

---

**Defining Orbital Parameters**

A great variety of satellite orbits can be propagated using the **Orbit Wizard** and **Satellite Database**. In addition, STK allows you to define any satellite orbit precisely using a number of propagators and force models. You will now add two satellites to the scenario using the J4 Perturbation propagator, which accounts for secular variations in the orbit elements due to Earth oblateness.

1. Create a new satellite and name it *ERS1*. If the Orbit Wizard appears, click Cancel.
2. Display the new satellite’s *Properties Browser* and open the *Orbit* page.

3. Enter the orbital parameters for ERS1, found in the following table. Use the down-pointing arrow to change the default RAAN (Right Ascension of the Ascending Node) option to Lon Ascn Node (Longitude of Ascending Node) before entering the values listed in the table.

<table>
<thead>
<tr>
<th>Orbital Element</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>1 Jul 2002 00:00:00.00</td>
</tr>
<tr>
<td>Stop Time</td>
<td>1 Jul 2002 04:00:00.00</td>
</tr>
<tr>
<td>Step Size</td>
<td>60.00</td>
</tr>
<tr>
<td>Orbit Epoch</td>
<td>1 Jul 2002 00:00:00.00</td>
</tr>
<tr>
<td>Coordinate Type</td>
<td>Classical</td>
</tr>
<tr>
<td>Coordinate System</td>
<td>J2000</td>
</tr>
<tr>
<td>Semimajor Axis</td>
<td>7163.14 km</td>
</tr>
<tr>
<td>Eccentricity</td>
<td>0.0</td>
</tr>
<tr>
<td>Inclination</td>
<td>98.50 deg</td>
</tr>
<tr>
<td>Argument of Perigee</td>
<td>0.0 deg</td>
</tr>
<tr>
<td>Lon Ascn Node</td>
<td>99.38 deg</td>
</tr>
<tr>
<td>True Anomaly</td>
<td>0.0 deg</td>
</tr>
</tbody>
</table>

4. When you finish, click *Apply*, and then click the (Reset) button.
5. Open the satellite's 2D Graphics Pass page.

6. To display only the descending side of the orbit, change Visible Sides from Both to Descending and click Apply.
7. Observe the change in the 2D Graphics window.

8. When you finish, return the Visible Sides option to Both and click OK.

9. Create another satellite and name it Shuttle. If the Orbit Wizard appears, click Cancel.

10. On the Orbit page for the Shuttle, select J4Perturbation as the Propagator.

11. Use the down-pointing arrow to change the default setting of Semimajor Axis to Apogee Altitude. The default Eccentricity option will automatically change to Perigee Altitude.

12. Enter the orbital elements for the Shuttle as given in the following table.
### Table 5. Orbital elements for the Shuttle

<table>
<thead>
<tr>
<th>Orbital Element</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>1 Jul 2002 00:00:00.00</td>
</tr>
<tr>
<td>Stop Time</td>
<td>1 Jul 2002 03:00:00.00</td>
</tr>
<tr>
<td>Step Size</td>
<td>60.0 sec</td>
</tr>
<tr>
<td>Orbit Epoch</td>
<td>1 Jul 2002 00:00:00.00</td>
</tr>
<tr>
<td>Coordinate Type</td>
<td>Classical</td>
</tr>
<tr>
<td>Coordinate System</td>
<td>J2000</td>
</tr>
<tr>
<td>Apogee Altitude</td>
<td>370.4 km</td>
</tr>
<tr>
<td>Perigee Altitude</td>
<td>370.4 km</td>
</tr>
<tr>
<td>Inclination</td>
<td>28.5 deg</td>
</tr>
<tr>
<td>Argument of Perigee</td>
<td>0.0 deg</td>
</tr>
<tr>
<td>Long of Ascending Node</td>
<td>-151.0 deg</td>
</tr>
<tr>
<td>True Anomaly</td>
<td>0.0 deg</td>
</tr>
</tbody>
</table>

13. When you finish, click OK.

### 2D Graphics Properties

You have already become acquainted with the Pass page of the satellite’s 2D Graphics properties. Now you will use the Shuttle to experiment with further graphics features.

1. Open the Properties Browser for the Shuttle, and select the 2D Graphics Attributes page.
2. Change the Line Style to dashed and the Marker Style to Plus, and click Apply.

3. Now select the Contours page.

4. In the Level Attributes area, click Remove All to remove any existing entries from the Level list.

5. In the Level Adding area, make sure the Add Method is set to Start, Stop, Step, then enter 0, 50 and 10 for the Start, Stop and Step values, and click Add.

6. In the Level list, highlight the first level (0.00) and turn OFF the Label option. Change the Color and/or Line Style and/or Line Width if you wish.

7. Repeat step 6 for the remaining levels.

8. Turn the Show option for Elevation Contours ON, and then click OK.

9. To see the contour levels, click the \( \text{(Reset)} \) button. Zooming in will provide a better view.
10. When you finish, zoom out to a normal 2D Graphics view.

*Note*

To zoom in on a region in the 2D Graphics window, click the ✿ (Zoom In) button in the toolbar, place the mouse pointer in one corner of the region of interest, hold down the left mouse button, and drag the pointer to the opposite corner of the selected region. You can do this repeatedly. To restore the full 2D Graphics window view, click the ✿ (Zoom Out) button as often as necessary.

Map Projections

In this section of the Tutorial you will create a second 2D Graphics window and become acquainted with some of the map projections available with STK.

Creating a New 2D Graphics View

1. From the **View** menu, select **Duplicate 2D Graphics Window → 2D Graphics 1 – Earth**.

2. When the second 2D Graphics window appears, move it so that you can see both 2D Graphics windows at once.
Hint

It may be helpful to float one of the 2D Graphics windows so that you can move it out of the workspace. Simply right-click on the window’s title bar, select Floating from the choices presented, hold down the CTRL key, and drag the window to the desired location.

3. Select the new 2D Graphics window, and click the button on the toolbar to launch its 2D Graphics properties window.

4. Open the Projection page.

5. In the Projection Format frame, change the Type to Perspective and the Display Coordinate Frame to ECI.

6. In the Center frame, enter -3.418 deg as the Latitude, 54.99 deg as the Longitude, and 35000 km as the Altitude.

7. Click OK to view the changes in the 2D Graphics window. If the satellite orbits do not appear, click the (Reset) button.
Sampling Map Projections

1. Select the original 2D Graphics window (2D Graphics - Earth), and click the button to display its properties.

2. Move the 2D Graphics properties window into a position where you can see it and the 2D Graphics window simultaneously.

3. Open the Projection page and open the Type list in the Projection Format frame.

4. The currently selected projection is Equidistant Cylindrical. Select any other projection (such as the Sinusoidal projection shown below), and click Apply to see it in the 2D Graphics window.
5. Browse through the available projections by repeating Step 4 for each projection listed in the dropdown list.

6. When you finish, restore the first 2D Graphics window to Equidistant Cylindrical, and click OK to dismiss the 2D Graphics properties window.

Adding an Area Target

Area targets are used to define geographical regions of interest on the ground. Assume that the Cruise ship has run into the Iceberg. You will now create an area target that defines the search area for survivors.

1. Insert an area target ( ) from the Object Catalog, and name it SearchArea.

2. Launch the area target’s Properties Browser, and open the 2D Graphics Attributes page.

3. Set the Marker Style to None.

4. Disable the Inherit from Scenario, Show Label and Show Centroid options.

5. Open the Basic Boundary page.
6. Click the Add… button to insert a boundary point. Double-click the field under Latitude and enter the value 78.4399. Similarly, double-click the field under Longitude and enter a value of –77.6125.

7. Repeat step 6 until you have entered all of the boundary points in the following table:

<table>
<thead>
<tr>
<th>Table 6. Area target boundary points</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latitude</td>
</tr>
<tr>
<td>78.4399</td>
</tr>
<tr>
<td>77.7879</td>
</tr>
<tr>
<td>74.5279</td>
</tr>
<tr>
<td>71.6591</td>
</tr>
<tr>
<td>70.0291</td>
</tr>
<tr>
<td>71.9851</td>
</tr>
</tbody>
</table>

8. Now open the Centroid page.
9. Turn off the Auto Compute Centroid option and change the Position Type to Spherical.

10. Enter 74.9533 as the Latitude, -74.5482 as the Longitude, and 6358.186790 as the Radius.

11. Click OK.

12. Zoom the 2D Graphics window in on the region around the area target; then, when you are finished, zoom out again.

Calculating Access

Now you will calculate access from the ERS1 satellite to the area target to determine whether the satellite can view any of the wreckage and help in the search efforts.
1. In the Object Browser, highlight ERS1, right-click the mouse, and select Satellite Tools → Access.

2. When the Access window appears, select SearchArea in the Associated Objects list and click Compute. Portions of the satellite's ground track are highlighted in the 2D Graphics window to indicate periods of access to the area target.

3. Now click Access... in the Reports area to view an Access Summary Report. As you can see, during the four-hour interval defined by the satellite's time period, there are three periods of access totaling nearly 50 minutes.
4. Close the report.

5. In the Access window, click the Remove Access button, and then click Close.

Working with Sensors

In this exercise you will first attach sensors to a satellite and experiment with sensor pointing types. Then you will attach a sensor to a ground facility and limit its visibility to objects a certain distance above the horizon.

Defining and Pointing Sensors

1. With the ERS1 satellite selected in the Object Browser, insert a sensor (Sensor) from the Object Catalog. Name the new sensor Horizon.

2. Launch the sensor’s Properties Browser, and open the Definition page.
3. Make sure the Sensor Type is set to Simple Conic and the ConeAngle is 90 deg. Open the Pointing page.

4. You want to point the sensor straight down relative to the ERS1 satellite. To do this, verify that the Pointing Type is set to Fixed and Elevation is set to 90 deg.

5. Click OK.

6. Unclutter the 2D Graphics window a bit by removing the Shuttle's contour graphics. Open the 2D Graphics Contours page for the Shuttle, turn off the Show option for Elevation Contours, and click OK.

7. In the first 2D Graphics window (2D Graphics - Earth), click the (Reset) button, and then click the (Animate Forward) button. Note the graphics representing the Horizon sensor's field of view (shown here zoomed).
8. Stop the animation by clicking \( \text{Reset} \) or \( \text{Pause} \).

9. Add another sensor to the ERS1 satellite and name it Downlink.

10. Open the new sensor's **Definition** page.

11. Select Half-Power as the Sensor Type.

12. Set the Frequency to 0.85 GHz and the dish Diameter to 1.0 meter. STK computes the half-angle for you.

13. Open the **Pointing** page.
14. Change the Pointing Type to Targeted and the Boresight Type to Tracking.

15. Select the Baikonur facility in the Available Targets list and use the Add button to copy it the Assigned Targets list.

16. Repeat Step 15 for each facility until all the facilities appear in the Assigned Targets list.

17. Click OK.

18. Animate the scenario and let the animation run until the ERS1 satellite moves over the Santiago facility (shown here zoomed).

19. Click the [ ] (Reset) button to stop the animation.
Limiting a Sensor's Visibility

Now you will attach sensors to a couple of ground facilities and limit their visibility.

1. Attach a sensor to the Wallops facility and name it *FiveDegElev*.

2. Open the new sensor’s **Definition** page.

3. Set the **Sensor Type** to *Complex Conic*, the **Inner Half Angle** value to 0 deg and the **Outer Half Angle** value to 85 deg, the **Minimum Clock Angle** to 0 deg and the **Maximum Clock Angle** to 360 deg.

4. Now open the **Pointing** page, and make sure that the **Pointing Type** is set to *Fixed* and that **Elevation** is set to 90 deg.

5. Open the **2D Graphics Projection** page.
6. Set the **Maximum Altitude** to **785.248 km** and the **Step Count** to **1**.

7. Click **OK**.
8. You can reuse the new sensor. Highlight the FiveDegElev sensor in the Object Browser and select **Copy** from the **Edit** menu.

9. Now highlight the WhiteSands facility in the Object Browser window and select **Paste** from the **Edit** menu.

10. Open the **2D Graphics Attributes** page for the new sensor, and change the **Color** to the color of the WhiteSands facility, so that the fields of view of the sensors attached to the WhiteSands and Wallops facilities are more clearly distinguishable. Click **OK**.

11. Click the **(Reset)** button if necessary to display the new color.
More Satellite 2D Graphics

In the examples presented thus far, the 2D Graphics window display of satellite ephemeris has been uniform throughout a satellite's time period. STK provides the option of specifying whether and, if so, how ephemeris should be displayed during selected time intervals or access events.

1. Open the Basic Orbit page for the ERS1 satellite, and set the Stop Time to 2 Jul 2002 00:00:00.00.

2. Click Apply to generate 24 hours of ephemeris for the satellite.

Custom Display Intervals

Suppose that you are interested in the location of the ERS1 satellite during the half-hour periods preceding noon and midnight.

1. Open the 2D Graphics Attributes page for ERS1, and select the Custom Intervals option.
2. Click the Add... button.

3. In the Add Graphics Interval window, set Start Time to 11:30 and End Time to 12:00 (noon).

4. Select a relatively bright Color that differs from that in which ERS1’s ground track ordinarily displays.

5. Make certain the Show and Inherit Settings options are ON, and click OK.

6. Click the Add... button again.
7. Set the **Start Time** to 23:30 and the **End Time** to 24:00. Note that the End Time (midnight) will automatically advance the date to 2 Jul 2002 00:00:00.00.

8. Select a **Color** for this pre-midnight interval that differs from the one you selected for the pre-noon interval (and also differs from the color in which the ephemeris normally displays).

9. Click **OK** to dismiss the **Add Graphics Interval** window.

10. Click **Apply** in the **Properties Browser**, and look at the 2D Graphics window. Two portions of the ERS1's ground track are highlighted. One, running from the South Atlantic to Canada, reflects ERS1's position during the half-hour before noon. The other, running from Southeast Asia to Greenland, shows the satellite's position during the half-hour preceding midnight.
Access Display Intervals

You can link the display of satellite ephemeris to periods of access between the satellite and one or more selected scenario objects, as in the following exercise.

1. With the Attributes page for the ERS1 satellite still open, click the Access Intervals option.

2. Highlight each facility in the Available Objects list and, using the Insert button, move it into the Selected Objects list.

3. In the Display Options frame, highlight No Access and click the More... button.

4. In the Modify Access Attributes window, turn on the Show option for Graphics Attributes.
5. Turn OFF the Inherit Settings option; then turn off the Show Label, Show Ground Marker and Show Orbit Marker options.

6. Click OK to dismiss the Modify Access Attributes window and again to dismiss the Properties Browser.

7. Launch the Properties Browser for the Horizon sensor and open the Display Times page.

8. Set Display Status to During Access, and click the Select Access Objects... button.

9. When the Select Access Objects window appears, highlight each of the facilities in the Available Objects list and click the right arrow to enter them in the Selected Objects list.
10. Click OK to return to the **Display Times** page, which now lists the time intervals corresponding to periods of access.

11. Click Apply, and then reset and animate the 2D Graphics window. The graphics for ERS1 and its attached sensors will appear only when there is access to one of the facilities.
12. Return to the Display Times page for the Horizon sensor, set Display Status to Always On and click OK.

13. Open the 2D Graphics Attributes page for the ERS1 satellite, select the Basic option and click OK.

Static & Dynamic Display of Data

The reporting and graphing capabilities of STK make it easy to display and analyze data developed during a scenario. Also, data that changes over the scenario’s time period can be displayed dynamically in the course of animation.

Reports & Graphs

This exercise illustrates one of the many standard report and graph options that are shipped with STK.

Note

In addition to standard report and graph styles, STK/Pro makes it easy to create custom reports and graphs to suit your particular analytical or operational needs.

1. Highlight the ERS1 satellite in the Object Browser, right-click the mouse, and select Satellite Tools ➔ Report.
2. In the window that appears, highlight the Solar AER option in the Styles list, and click the Create… button.

3. A report is generated, showing the azimuth, elevation and range of the Sun with respect to the ERS1 satellite at one-minute intervals throughout the satellite's time period.

4. Close the report, and then click Close to close the Report window.

5. Now, with the ERS1 satellite still highlighted in the Object Browser, right-click the mouse and select Satellite Tools → Graph.

6. Highlight Solar AER in the Graph window, and then click Create…
7. The data that was previously presented in a report is now displayed in graph form.

8. To change the color and/or other properties of any of the graph elements (e.g. because it does not show up distinctly), select Attributes… from the Graph menu in the main menu bar.

9. In the Attributes window, select the Element that you wish to change and, in the Line and Point frames, make any desired changes to Color, Style and/or Width or Size.

10. Click OK to dismiss the Attributes window.

11. Close the graph, and then click Close to dismiss the Graph window.

Dynamic Displays & Strip Charts

STK provides two ways to display data dynamically while a scenario is animating: a dynamic display of report-style data, or a strip chart presenting data in graph style.
1. Highlight the Shuttle in the Object Browser, right-click the mouse, and select Satellite Tools → Dynamic Display.

![Dynamic Display for Shuttle](image)

2. In the Dynamic Display window, select LLA Position from the Styles list, and click Open...

![Dynamic Display: Shuttle - LLA Position](image)

3. A dynamic display appears, with entries for time, latitude, longitude, altitude and corresponding rate data.

4. Position the dynamic display so that you can see it and the first 2D Graphics window (2D Graphics - Earth) simultaneously.

5. Animate the scenario. The Shuttle's positional and rate values will change as the animation progresses.

6. Pause the animation when the Shuttle is at or near its northernmost position in the 2D Graphics window. The displayed value for latitude should be in the vicinity of 28.5 deg. This corresponds to the Inclination that was set for the Shuttle when you defined its Orbit properties.
7. Click the \texttt{Reset} button.

8. Close the dynamic display, and then dismiss the \textit{Dynamic Display} window by clicking Close.

9. With the Shuttle still highlighted, right-click and select Satellite Tools \rightarrow Strip Chart.

10. In the \textit{Strip Chart} window, select Solar AER from the Styles list, and click Open...

11. If you want to change the color and/or other properties of any strip chart element, follow the same procedure as for graphs in the preceding section.

12. Position the strip chart window so that you can see it and the first 2D Graphics window simultaneously, and animate the scenario.
13. The strip chart shows azimuth, elevation and range information from the satellite to the Sun. Note that the range (distance) varies over a span of about 11500 km, representing the difference between the positions in its orbit nearest to and most distant from the Sun.

14. Click the (Reset) button, close the strip chart, and then click Close to dismiss the Strip Chart window.

Setting Constraints

In this section you will experiment with just two of the many ways in which STK allows you to constrain objects and thereby refine your analysis. In both cases you will impose constraints on the Horizon sensor attached to the ERS1 satellite.

1. Highlight the Horizon sensor (attached to the ERS1 satellite) in the STK Object Browser, right-click the mouse, and select Sensor Tools → Access.
2. Select the Baikonur facility in the Access window, and click Compute... The ground track of the ERS1 satellite is highlighted to indicate periods of access to the facility.

3. Now, with the Horizon sensor still highlighted in the Object Browser (and without dismissing the Access window), launch the sensor’s Properties Browser, and select the Sun page (under Constraints).
4. Turn on the Min(imum) option for Sun Elevation Angle, and set the value to 10 deg.

5. Click Apply, and note the change in access graphics in the 2D Graphics window.

6. Experiment with other values for Sun elevation angle, such as 0 deg, 5 deg, 15 deg and 20 deg, clicking Apply each time to see the results.

7. Turn off the Min(imum) option for Sun Elevation Angle, and then open the Basic page.
8. Turn on the Max(imum) option for Range, and set the value to 2000 km.

9. Click Apply, and observe the impact on access graphics in the 2D Graphics window.

10. Experiment with other values for maximum range, such as 1500 km, 1000 km and 500 km, clicking Apply each time to see the results.
11. When you are finished, turn off the Max(imum) option for Range, and click OK to dismiss the Properties Browser.

12. Click the Remove Access button in the Access window, and then click Close to dismiss the window.

Creating a Walker Constellation

Finally, you will become acquainted with a tool that allows you quickly to define and propagate a constellation of systematically spaced satellites with circular orbits having the same inclination and period. We will use the ERS1 satellite as a "seed" to generate the constellation.

1. Highlight the ERS1 satellite in the Object Browser window, launch its Properties Browser, and open the Orbit page.

2. Change the Stop Time for the satellite to 1 Jul 2002 06:00:00.00, and click OK.

3. With the ERS1 satellite still highlighted, right-click the mouse and select Satellite Tools → Walker.

4. In the window that appears, make certain that Delta is selected as the Type, RAAN Spread is set to 360 deg, and the Color by Plane option is turned on.

5. Set Number of Planes to 2, Number of Sat(ellite)s per Plane to 3, and Inter Plane Spacing to 1.

6. Click OK.
7. Six new satellites appear in the Object Browser, each with an automatically generated name based on the name of the seed satellite. Each of the newly created satellites has two sensors with the same properties as those of the sensors attached to the seed satellite.

8. Click the **(Reset)** button, and animate the scenario.

9. Observe how the (targeted) Downlink sensor pattern appears in the 2D Graphics window as each satellite passes near a facility.

10. Click the **(Reset)** button.

**Conclusion**

This concludes the tutorial. But we barely scraped the surface. As you undoubtedly noticed while working through these exercises, for each properties page you opened, for each menu item you selected, for each option you tried out, and for each tool you used, there were many dozens we had to skip over.
So, why not take another voyage through the tutorial, this time exploring some detours and browsing through some of the many properties pages, menus and tools you find along the way?