Install Network Connect

Last Updated: 04/25/2014
Layout:
One Column
Two Column

Overview

Admin access is required to install Network Connect. View the system requirements below.

Note: Java is also required to run Network Connect. Visit Java's Download Options page to find the version appropriate for your operating system. However, updating to Java version 7 update 45 is not recommended due to a known incompatibility between Java and Network Connect.

This tutorial applies to the following operating system(s):
  • MAC
  • WINDOWS
  • LINUX
  • Mac OS 10.5- 10.8 - You will need to use Safari as your browser to complete the steps below. Safari will allow you to access the Network Connect "Start" button.
  • Mac OS Known Issue - Due to an issue with Safari and Network Connect, Mac OSX 10.9 users (possibly other OSX users, if using Java 1.7.0_45) cannot install Network Connect through the traditional installation method. Refer to the Manually Install Network Connect tutorial to learn how to install the Network Connect DMG manually.

Step 1

Step 2

Go to the VPN login page: https://cuvpn.colorado.edu.

Step 3

Log in with your CU Login name and IdentiKey password.

Step 4

Your web browser may prompt you to install a Juniper application the first time you log in. You also may be prompted to accept a certificate, both of which you should do.

Step 5

Once logged in you will be connected to CUVPN.

Step 6

In the Client Application Sessions section, click on the Start button associated with Network Connect.

Step 7

You will be prompted to install Network Connect. Click Yes and follow the installation process.

Step 8

A window will open, displaying your connection.

Step 9

Click Sign Out in the browser to when finished with you session.

Network Connect System Requirements

To download and use Network Connect, your system must have the following:

  • Operating Systems and Browsers for Core Access Web Browsing, File Sharing, SSH.
    • Operating Systems:
      • Windows XP or later
      • Mac OS 10.5-10.8
      • OpenSuse 10.x and 11.x (32-bit only)
      • Ubuntu 9.10 and 10.x (32-bit only)
      • Red Hat Enterprise Linux 5 (32-bit only)
      • Solaris 10 (32-bit only)
    • Browsers for Windows
      • IE 7 and above
      • Firefox 3.0 and above
      • Sun JRE 6 and above
    • Browsers for Mac
      • Safari 3.0 - 6.0 (Mac OS 10.5-10.8)
    • Linux
      • Firefox 3 and above
      • Sun JRE 6 and above
  • Requirements for NetConnect

    • Above Operating Systems and Browsers along with:

      • Antivirus software (CU-recommended antivirus or Juniper-supported clients).

      • Firewall (Windows Firewall and Juniper-supported clients are accepted).

Was this helpful?

Back to top