Browser Update Notice June 2014

Last Updated: 09/01/2014

Security Notice Level

SEVERE

Mozilla and Google have released updated versions of their respective browsers. If left unpatched, these vulnerabilities may allow attackers to execute arbitrary code, cause a denial of service, conduct clickjacking attacks, or take control of the affected system.

Affected Software

The IT Security office advises owners of the affected browsers to restart their browser or follow update instructions to facilitate updating.

  • Versions of Firefox prior to version 30
  • Versions of Google Chrome prior to version 35.0.1916.153 (Windows/Mac/Linux) 

Security Bulletin Names

  • Security Advisories for Firefox – released June 13, 2014
  • Google Stable Channel Update – released June 10, 2014 

Additional Information

Additional information about this vulnerability can be viewed at:
http://www.mozilla.org/security/known-vulnerabilities/firefox.html
http://googlechromereleases.blogspot.com/2014/06/stable-channel-update.html
 
If you have any questions, please contact the IT Service Center at 303-735-4357 (or 5-HELP from an on-campus phone) or help@colorado.edu.