Browser Update Notice April 2014

Last Updated: 04/30/2014

Security Notice Level

SEVERE

Mozilla, Google, and Apple have released updated versions of their respective browsers. If left unpatched, these vulnerabilities may allow a remote attacker to obtain sensitive information, cause a denial-of-service condition, execute arbitrary code, conduct phishing attacks, conduct man-in-the-middle attacks, cause memory corruption, or allow operating with elevated privileges on an affected system.

Affected Software

The IT Security office advises owners of the affected browsers to restart their browser or follow update instructions to facilitate updating.

  • Versions of Firefox prior to version 29
  • Versions of Google Chrome prior to version 34.0.1847.131 (Windows/Mac) and 34.0.1847.132 (Linux)
  • Versions of Safari prior to 7.0.3 and 6.1.3

Security Bulletin Names

  • Security Advisories for Firefox – released April 29, 2014
  • Google Stable Channel Update – released April 24, 2014
  • Apple Article:  HT6181 – modified April 22, 2014

Additional Information

Additional information about these vulnerabilities can be viewed at:

If you have any questions, please contact the IT Service Center at 303-735-4357 (or 5-HELP from an on-campus phone) or help@colorado.edu.