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Section 3: Tutorial

3.1: Introduction
The ability to manipulate light in free space where losses are low allows the creation of complex optical systems. 
These systems can be designed with far fewer amplifiers, and in some cases without any amplification at all. The 
compact nature of MEMS optics also enables applications in which devices can replace conventional macroscopic 
optics, to provide a lower cost solution. 

This section provides an opportunity to gain experience with Designer while creating a practical system design. The 
tutorial presents step-by-step guidance for building a thermally-actuated optical mirror assembly. The finished 
assembly is an example of a device that may be used in various optical applications. It features a moving mirror and a 
thermal actuator, known as a heatuator. A 3-D simulation of the final assembly is shown in Figure D3-3.

3.1.1: The Thermally-Actuated Pop-Up Mirror
The thermally actuated mirror design has numerous applications, including optical switching and scanning. Figure 
D3-1 shows an image of a Multi-User MEMS Processes (MUMPS)-fabricated pop-up mirror. This image was cap-
tured using a scanning electron microscope and is similar to the one you will build in this tutorial.  

Figure D3-1 SEM Image of Pop-up Mirror  

The mirror is controlled by an array of actuators connected to the mirror, as shown in Figure D3-2. 
 

Figure D3-2 SEM Image of Complete Scanning Micromirror Assembly  

Locking tether

Actuator array

Pop-up mirror
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Figure D3-3 Designer 3-D Model of Micromirror Assembly  

3.1.2: Additional Technical Details
The mirror that makes up part of the device is known as a pop-up mirror because it is flat when fabricated, but 
extends out from the wafer plane when in use. It uses a layer of gold as its optical reflector. In this design, the mirror 
is manually assembled to a nearly vertical position and locked in place by a rod connected to the actuator. The mirror 
rotates around pins that are held to the substrate by staple-like structures that function as hinges.

The thermal actuator, or heatuator, uses differential thermal expansion to provide high forces and substantial linear 
motion. To increase the available force, this design uses a parallel combination of ten thermal actuators. The heat is 
generated by passing current through the device. This actuator is designed to pull the mirror in order to avoid flexing 
the connecting rod. Each actuator is capable of over 20�N of force and over 10�m of deflection at an input electrical 
power of 25mW (at 5V and 5mA). A 5 x 2 array used here can provide 200�N of force while consuming 250 mW.

The conductors used to feed this device are thick enough to prevent significant parasitic voltage drops for 50 mA of 
current and to reduce the associated power loss. Because this is a significant amount of power, the fabricated chip 
must be bonded to a thermally efficient heat sink. 
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3.2: Using the Tutorial
This tutorial is written for two different participant levels. For each major procedural sequence, general procedural 
guidelines are provided for users who have used the Layout Editor before, have been through this tutorial more than 
once, or who can easily figure out how to perform the required steps with minimal instruction. Detailed procedures 
have been included for less-experienced users. These guidelines are specific and include screen illustrations and 
explanations for additional clarity. 

3.2.1: Detailed File Description

Design Kits and Design Rules

Typically, a template file, process file, mpd file, and Design Rules are included in a foundry design kit. Accordingly, 
sample Design Kit files have been included in this tutorial. These are designated foundry.cat, foundry.proc, and 
foundry.mpd and are described above. 

Design rules are limitations or considerations that must be taken into account when constructing a drawing to ensure 
that model fabrication is actually possible. Because the purpose of this tutorial is to provide experience with the Cov-
entor Layout Editor, these considerations were taken into account when the tutorial was created and need not concern 
the user while building the model. This is intended to allow the student to focus more fully on the capabilities and 
functionality of the tool. For more information on design kits, see “Design Kit Components” on page D2-13.

File Name Description of provided files

foundry.cat Template file with prespecified layers used in creating your first library. Select this file from the 
navigation window that appears after you start the Layout Editor and select from the menu bar File > 
New > From Template ...

foundry.proc Process Editor file used to create the 3-D solid model. This file is in the Devices directory and is 
selected through the Browse function of the Process field on the Foundry tab.

foundry.mpd MPD file used to store materials used by Process Editor. This file is in the Devices directory and is 
selected through the Browse function of the Materials field on the Foundry tab.

partial_cells.cat Library containing partial design assemblies prebuilt to save time in completing the tutorial. 

completed.cat A completed library that contains all the cells and assemblies used in the tutorial sequence. Use this 
library to check your work or to copy completed cells to your own library if necessary.

micromirror.cat Name of the library file you will create while running the tutorial (it does not exist initially). This file 
will reside in the same directory as the other tutorial libraries.

File Name Description of generated files

Work files Build Model files created by the Layout Editor when building a 3-D model.

Temp files Temporary program files with *.log and *.cmd extensions and cat*.tmp directories.

Solid Model file The sat file must be named before the model can be built. Select the name or browse to a file to be 
replaced from the Browse function of the Solid Model field on the Solid Model tab. 



Section 3: Tutorial March 12, 2002                                                                   Version 2001.3

D3-4 Coventor, Inc. 

 

3.2.2: Recovering from Mistakes 
The Layout Editor is a flexible tool that allows you to complete sequences in many different ways. If you do not suc-
cessfully complete a part of the tutorial, you can almost always get back to a safe point or successfully complete the 
task in a different way. If you get into trouble, here are some recommendations:

Interrupt a Current Command

While drawing or performing another action, you may have made a mistake. You can stop and cancel out of a com-
mand sequence at any time in one of two ways:

1.Click on the red Stop icon in the lower right corner of the window; or
2.Press Esc on the keyboard.

Undo an Action

The Layout Editor offers unlimited sequential levels of Undo while drawing in a specific cell. This feature resets each 
time the cell is saved. 

1.From the lower horizontal icon row, select Undo. Your last action is undone. You may continue clicking on 
Undo to back out of as many commands as desired.

2.You may also click on the arrow next to Undo. You can undo as many listed actions as desired.

Redo an Action

The Layout Editor offers unlimited sequential levels of Redo after performing Undo operations.  
1.After you have performed an Undo, you may redo an action by clicking on the Redo icon. Your last action 

is redone. You may continue clicking on Redo until the list is exhausted.
2.You may also click on the arrow next to Redo. You can redo as many listed actions as desired.

Redraw the Screen  

Occasionally, you may find that the drawing area displays information from previous operations that is no longer 
valid. You can clean up these artifacts very simply. This procedure may be especially useful if you are having a diffi-
cult time selecting an object — it may not really be there.

1.From the lower horizontal row, click on the Refresh screen icon.
2.To be sure that the canvas screen automatically refreshes (for most operations), click on the arrow next to 

the Refresh screen icon and be sure that the Auto-refresh menu entry is checked (it is checked by default).

How to Save Your Work
Be sure to save your work in the event of a computer crash. Saving your library saves your work to 
disk. However, saving a cell does not save to disk.  

1.From the upper horizontal icon row, click on Save File. Your library work is saved.
2.Even better, click on the arrow next to Save File and select Save File As.... Save your 

work to a new name, using some designation to show how far along the backup file has 
progressed (such as micromirror_03.cat if you have successfully completed Step 3 of this 
tutorial).
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Verify Accuracy of Your Work  

After drawing an object, you may not be sure that it is on the correct layer, or that its dimensions are correct. The 
Modify > Object command allows you to check any object on the canvas. 

1. From the menu bar, select Modify > Object ...
2. Click on the desired object to select it.
3. Review the object’s properties in the dialog window that opens:

 

A different dialog window opens for each different object type (rectangle, arc, etc.).

Object
Each dialog window has an object field. The java reference is a unique identifier that can be ignored.

Layer
Single object windows display the layer. Change the layer name by overwriting the field or by clicking on the 
down arrow and selecting a layer.

Rectangle
Every window has a coordinate entry. In this example, the coordinates of the lower left and upper right vertices 
defining a rectangle are shown. Overwrite any number in the field to change the rectangle dimensions.
4. Apply and Close to make changes and end the sequence.

Copy Cells from Another Library  

If your work is incorrect and cannot be fixed, or if you want to start from a point in the tutorial other than the begin-
ning, you may import or overwrite your cells with cells from the completed.cat file into your micromirror.cat library. 
Simply copy the cell or cells called out in the tutorial, and the design will be complete up to that point. 

1. From the menu bar, select Cell > Copy ...
2. In the dialog window, enter the fields as shown in this illustration:

    

3. The source library for this tutorial is the completed.cat file. 
4. Choose a Source cell from this library by clicking on the Browse button.
5. The Destination cell should have the same name.
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6. If cell exists, you normally want to overwrite to substitute the known good cell from completed.cat.
7. Always Copy nested cells to be sure that all the cell references are copied to your new library.
8. Apply and Close to end the sequence.
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3.3: Draw a Four-Layer Optical Mirror

3.3.1: Objective
Start from a blank canvas screen and build the mirror mechanism.

3.3.2: Specific Skills
� How to start Designer
� How to use a template file
� How to set the grid
� How to use the Terminal window
� How to select from the Layer list
� How to zoom to view all objects
� How to place coordinates with the mouse
� How to enter coordinates from the keyboard
� How to build a polygon
� How to build a circle
� How to use the Repeat Mode
� How to save your work

3.3.3: Procedural Guidelines for Advanced Users 
1. Start Designer. (New users go to “Procedure for New Users” on page D3-8) 
2. Create a new file micromirror.cat from the template file foundry.cat.
3. Draw a four-layer mirror using Table D3-1 as a guide. 
4. Save the cell as mirror.

Table D3-1       Mirror Object Summary      

The completed work should look like that shown in Figure D3-4:

Layer Color Fill Object First coord Value Second coord Value

poly2 blue none rectangle lower left vertex -50, 0 upper right vertex 50, 100

p12via orange none circle center 0, 50 point on radius 47, 50

metal cyan solid circle center 0, 50 point on radius 46, 50

poly1 green solid rectangle lower left vertex -54, -4 upper right vertex 54, 104
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Figure D3-4 

   

3.3.4: Procedure for New Users 

Step 1-a What To Do What is accomplished

Start 
CoventorWare 

a. NT users: Click on the desktop icon.
b. UNIX users: Type the command 

coventorware to launch the application.

� During installation, the desktop icon shortcut is 
configured to point to the correct files.

� Screen illustrations appear on page D3-10.

Import the 
tutorial

a. Select the Import Tutorial icon
b. Scroll down and select Designer. Click on 

Open and then OK.
c. The Designer project just imported is 

selected by default from the project list.
d. Enter designer.mps and click on Open.

� You must specify a project and name the Designer 
Project Settings (.mps) file to proceed.

� The program generates a default name for the Project 
Settings file, which may be accepted or changed.

Start the Layout 
Editor

Select the Start Layout Editor icon. It is not necessary to select a template on the Layout tab. 
The template is selected inside the Layout Editor.

Create a new 
file from the 
template file 
foundry.cat.

a. From the Layout Editor menu bar, select 
File > New > From Template... 

b. In the Template file name navigation 
window that opens, select foundry.cat, and 
click on Open.

� The new file will have some settings from a 
previously prepared file. The settings transfer to the 
new file, acting as a template.

� The saved file is your working library.
� When the new file is opened, it automatically opens a 

new unnamed cell in an unnamed library.
� When using a foundry specific cat file, substitute that 

file name.
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Save the library 
file   

a. From the upper horizontal icon row, click 
on the arrow next to the diskette icon.

b. Select Save File As...
c. Save the file as micromirror.cat.

� This action saves the new cat file in the same 
directory as the other tutorial files.

� Save your work often.

Verify the 
workspace

a. Move the cursor to the lower left corner of 
the black window area; observe the 
coordinates in the lower left of the screen.

b. Do the same for the upper right corner.

If you haven’t changed the default size, your visible 
workspace is about 60 x 60 units. More workspace will 
be needed to complete this initial sequence.

Change the grid 
setting

a. Slowly move the mouse to detect the 
allowable incremental (snap) movement.

b. From the menu bar, select Other > Grid ...
c. Change the Working Grid to 1.0.
d. Click on Apply, then Close the window.

� Your default working grid is 0.5 units, and your 
display grid is twice that or 1 unit. 

� This changes the grid to 1.0 unit. The multiple of 2 
means that the dot spacing increases to double the 
grid setting. The Display Grid Multiple should not be 
changed.

� Note that the coordinate range of the canvas does not 
change. You cannot build and view a larger object 
with only a grid change. 

Open the 
Terminal 
window.

Click on the small square to the left of the 
prompt line at the bottom of the drawing area.

You can observe the command execution in more detail 
in this window. If it is distracting, you can close or 
minimize it at any time.

Coordinate Entry
In the next sequence, you will be instructed to use the mouse to place drawing coordinates. If you have 
problems in navigating to the exact coordinates, you may type the coordinates right next to the one-line 
prompt at the bottom of the canvas window.

Refer to “Deposited Layers” on page D4-16 for more details on the layers and layer names used in this 
design.

To save your work:
You must save the library file, not just the cell. Click on the top icon row diskette icon.

If you make a mistake:   Refer to “Recovering from Mistakes” on page D3-4. If you make a serious 
mistake, refer to “Copy Cells from Another Library” on page D3-5

If you are having a difficult time using the mouse to place coordinates:   
Type the coordinates in the Command Line at the bottom of the canvas window.

If you need to check the coordinates or layer name of any placed object:
Refer to “Verify Accuracy of Your Work” on page D3-5.

If the screen appears to have unusual leftover graphic information: 
From the lower horizontal row, click on the Refresh screen icon.

Step 1-a What To Do What is accomplished
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Figure D3-5 Screen Illustrations 
   

click here for Terminal window

vertical icons

upper row icons
lower row icons
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Step 1-b What to do What is accomplished

Using the Current layer 
selector   

a. Along the top of the window, observe the left-most 
field in the lower horizontal icon row. Move the 
mouse over the area to see it identified as Current 
layer.

b. Click on the arrow to the right of the layer name.

� The Current layer is a short form view 
of the Layer Browser window. 

� You can view and select from any of 
the layers created for the cell from the 
Template file.

Build your first 
rectangle 
(100 by 100 units)  

a. From the Current layer list, select poly2.
b. Along the vertical icon column, select the 

Rectangle icon.
c. While viewing the coordinate reading in the lower 

left corner of the canvas window, move the mouse 
to the left in an attempt to reach coordinate -50, 0.

d. If you run out of room, click on the Zoom Out icon 
in the lower horizontal row while still in the 
Rectangle command.

e. Now move to coordinate -50, 0 and click.
f. Move the mouse to coordinate 50, 100 and click, 

using Zoom Out as required.
g. View your work by selecting the View All icon in 

the lower horizontal row.

� You can start drawing in the unnamed 
cell at this time without having to name 
it.

� The cursor moves in 1 unit increments.
� You can change magnification without 

terminating the command.
� You have entered the opposite diagonal 

coordinates of the rectangle.
� Zoom to View All, to see the entire 

rectangle.
� The rectangle should be a blue outline. 

See Figure D3-6.

With Repeat Mode on, 
   

build a circle

(47 unit radius)

a. From the Current layer list, select p12via.
b. Along the lower horizontal icon row, click on Turn 

Repeat Mode On.
c. From the vertical icon column, select the Circle 

icon.
d. In response to the Enter center coordinate prompt, 

move the mouse to coordinate 0, 50 and click (to 
define the center).

e. In response to the Enter point on radius prompt, 
move the mouse to coordinate 47, 50 and click (to 
define the radius).

� Turning Repeat Mode On allows you 
build additional circles without having 
to select the icon again.

� The first coordinate is the circle center.
� The second coordinate is the radius, 

entered as a coordinate on the circle.
� The circle should be an orange outline 

nested within the blue rectangle.

Build another circle
(46 unit radius)

a. From the Current layer list, select metal.
b. Place coordinate 0, 50.
c. Place coordinate 46, 50.
d. Right click to end the prompts for more circle 

coordinates.

� The circle should be a cyan filled object 
nested within the orange circle.

� Repeat Mode is still on for any new 
actions. 

Build another rectangle
(108 by 108 units)

a. From the Current layer list, select poly1.
b. Select the Rectangle icon.
c. Place coordinate -54, -4 (zoom as necessary).
d. Place coordinate 54, 104. 
e. Right click to end the rectangle coordinate 

prompts.

� The rectangle should be a green filled 
object that overlaps all previous objects 
and partially obscures them.

� When you right click to cancel from a 
command, you must reselect the 
command the next time.
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Figure D3-6       Four Sequenced Layers

Save your work  

and Refresh screen

a. Along the top icon row, click on the arrow next to 
the diskette icon and select Save Cell As...

b. In the window, enter mirror.
c. Click on OK.
d. Click on the diskette icon to save the library. It will 

overwrite your micromirror.cat file.
e. Click on the lower icon row Refresh screen icon to 

redraw the screen (if necessary).

� Your working cell is now named.
� Note that saving a cell does not write 

information to disk.
� Save your work by saving the library.

Step 1-b What to do What is accomplished

poly2 p12via

metal poly1
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3.3.5: Review Questions
Where did all these different colored layers come from?

The complete layer list was prepared for you and included in the foundry.cat file. When you used this file as a 
template, all the layer settings transferred to your new micromirror.cat file that you are in the process of creating.

Why do you have to enter two numbers to define the radius of a circle?
The Layout Editor is set up for X,Y coordinate entry for all shapes, including the circle. To make it easier to cal-
culate the coordinate required, choose the radius line to lie on the X axis defined by the circle center (or in other 
words, at the 3 o’clock position on the circle). Then the coordinate to define the radius can be reduced to a simple 
formula: (Xradius = Xcenter + radius)   (Yradius = Ycenter)

Can you change the sequence of the steps used to create the shapes shown?
Depending on what you are trying to accomplish, you often can perform these steps in different sequences. Spe-
cific polygons can be built in any sequence desired. Commands can be executed with interruptions from other 
commands and still work properly. This feature in the Layout Editor is known as nesting. The Layout Editor will 
tell you if you are trying to nest commands in an illegal sequence, so feel free to try various ways of completing 
a task.

If I save a cell and my computer system crashes, is the information saved to disk?
No. Saving a cell performs only a local memory save. To be sure that your work is saved at any given point, you 
must also save the library file. Saving the library file updates the file stored on disk.



Section 3: Tutorial March 12, 2002                                                                   Version 2001.3

D3-14 Coventor, Inc. 

3.4: Add Components and Create 3-D Model

3.4.1: Objective
Add a previously drawn cell to the existing mirror, supply process file information, and build and render a 3-D model 
of the mirror assembly.

3.4.2: Specific Skills
� How to place a reference cell
� How to copy cells from other libraries
� How to view hierarchy levels
� How to create a new layer
� How to set the file paths
� How to build a 3-D model
� How to view a 3-D model
� How to use a clip layer

3.4.3: Procedural Guidelines for Advanced Users
1. Start a new cell.
2. Add the mirror as a cell reference at origin 0, 0.
3. Copy popupmech from partial_cells.cat and add as a cell reference at origin 0, 0.
4. Copy the remaining cells in partial_cells.cat for future steps.
5. Add a red clip layer with coordinates -59, 50   59, 105.
6. Save your assembly as popup.
7. In the Designer Setup window, enter the file path for the work directory, the foundry.proc file, and the MPD 

file (see page D3-3). Be sure the Layout Editor Top Cell is popup.
8. Build a 3-D model using the clip layer.
9. View the model in the Preprocessor.
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3.4.4: Procedure for New Users 

Figure D3-7   Reference Dialog Window  

Step 2-a What to do What is accomplished

Start a new cell    a. Along the top icon row, click on the arrow next to 
New File. 

b. Select New Cell.

� This starts a new unnamed cell.
� Do not click on the icon. Doing so starts a 

new library.

Create a cell 
reference    

a. From the vertical icon column, select the Reference 
icon.

b. In the dialog window that opens, (see Figure D3-7) 
click on the Browse button next to Cell, and select 
mirror.

c. In the Origin field, enter 0, 0.
d. Click on Apply and Close.
e. Click on the View All icon in the lower horizontal 

row.

� This adds the completed mirror cell to the 
current cell by linking it as a reference. 

� You should now see the entire assembly.

Copy a cell from 
the partial_cells 
library

a. From the menu bar, select Cell > Copy ...
b. In the dialog window that opens, next to the Source 

library field, click on Browse... and select the 
partial_cells.cat file.

c. Next to the Source cell field, click on Browse... and 
select popupmech.

d. In the Destination field, type popupmech.
e. Click on Apply 

� You are copying a pre-built cell from the 
partial_cells.cat library.

� Copying makes it easier to complete the 
tutorial, because you don’t have to build 
the cell yourself.

� If you want to skip steps later on, you can 
copy completed cell assemblies from the 
completed.cat file (See “Copy Cells from 
Another Library” on page D3-5).

� See Figure D3-8  for a detailed 
explanation of the cell copy concept.

� Do not close the dialog window yet.

Copy the other 
three cells

a. Continue using the same copy procedure to copy the 
other four cells into your existing library.

b. When finished, Close the dialog window.

All of these cells will be used in the tutorial.

Check to see that 
the cells are copied  

a. From the upper icon row, click on the Cell browser 
icon at the far left.

b. Verify that the cell list looks as shown in item #4 of 
Figure D3-8 

� The browser lists all cells in the design.
� Your current Unnamed cell is in blue.
� Keep the Layout Editor Cell Browser 

open.
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Figure D3-8  Illustration of the Concept of Copied Cells
   

The current working library is micromirror.cat.

It contains the mirror cell saved in Step 1.

It also contains the new current working Unnamed cell.

The library named partial_cells.cat contains 

five cells previously built for your convenience.

Use the Cell > Copy command to copy cells from the partial_cells 
(source) library to your working (destination) library. The cell names are not changed during the copy 
procedure.

1

2

3

After copying all five cells from partial_cells.cat, 
your working micromirror.cat library will look like this:4
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Step 2-b What to do What is accomplished

Create another 
cell reference 
(popupmech)  

a. From the vertical icon column, select the Reference 
icon.

b. In the dialog window that opens, click on the Browse 
button next to Cell, and select popupmech.

c. In the Origin field, enter 0, 0.
d. Click on Apply and Close.
e. Click on View All.

� You are adding another existing cell to the 
current cell by linking it as a reference. 

� The cell is a hinge mechanism that allows 
the mirror to pop up.

� This reference cell can be edited without 
opening it; all changes are reflected in the 
cell when you save it.

Create a new clip 
layer    

a. Click on the Layer browser icon, next to the Current 
layer list.

b. In the window that opens, from the menu bar, select 
Layer > New...

c. In the dialog window, enter the Layer name clip.
d. Click on the Color name arrow and select the color 

red from the menu.
e. Click on Apply and Close.

� The clip layer will be used in the next sub-
step. 

� The layercreate dialog box is shown in 
Figure D3-9.

Build a clip 
rectangle

a. Select the clip layer.
b. Select the Rectangle icon.
c. Place coordinates -59, 50 and 59, 105.
d. Right click to end the prompts for more rectangle 

coordinates. 

� The clip layer is a red outline that cuts the 
underlying objects in half.

� Repeat Mode is still on for any new 
actions.

Save the cell and 
library   

a. Using the arrow next to the diskette icon, select Save 
Cell As...

b. In the window, enter popup; click on OK.
c. Click on the diskette icon to save your 

micromirror.cat file.

� The working cell is now named.
� Your library is overwritten with the latest 

data.

Check the 
hierarchy of the 
reference cells

a. From the menu bar, select View > Levels and uncheck 
Level 1. Observe results.

b. When finished, from the menu bar, select 
View > Levels > All.

c. In the Layout Editor Cell Browser window, click on 
the + next to popup and observe the reference cells.

� Placing cell references creates hierarchy in 
the design.

� The references are located at Level 1.
� When Level 1 is turned off, only the clip 

rectangle remains.
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Figure D3-9     Creating the Clip Layer

 

Step 2-c What to do What is accomplished

Set Source Catapult 
File and Top Cell fields

a. On the Layout tab of the Function Manager, verify or 
set the Source Catapult File to 

     Designer\Devices\micromirror.cat.
b. Verify or set the Top Cell field to popup.

Use information in the top level popup 
cell to build the model. This cell is part 
of the micromirror.cat library.

Begin setting file paths Select the Foundry tab. See Figure D3-10 Both a process (.proc) file and MPD 
(material properties database) file are 
necessary for creating a solid model.

Set the Process file 
path  

                      

In the window of the Process field, set the path to the 
Designer\Devices directory and select the foundry.proc 
file. Navigate using the folder icon next to the field.

� The Process Editor file provides the 
depth information to create a 3-D 
model.

� For this and the remaining steps on 
this page, refer to page D3-3 for 
more details on the specified files.

View the Process 
Editor file   

  (Setup window icon)

a. Select the Foundry tab.
b. Click on the icon to the right of the Process File field 

to open the process Editor.
c. Close when finished.

The Process Editor window (Figure D3-
11) shows the complete process 
sequence for the design.

Create file name for 
solid model 

a. From the Function Manager, select the Solid Model 
tab.

b. A default sat file will appear in the Solid Model 
field. Verify that the Solid Model File is named 
micromirror.sat

� Use information in the top level 
popup cell to build the model. This 
cell is part of the micromirror.cat 
library.

� All files necessary for building a 
solid model are selected or named.

� For now, ignore the Clip Device with 
Mask check box and field. Ensure 
that no other options are selected.
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Figure D3-10    

Figure D3-11    Process Editor Window

 

Step 2-e What to do What is accomplished

Build a 3-D Model a. Click on Build Model.
b. The Preprocessor opens automatically after a 

successful build.

� The 3-D model is built.
� Progress may be observed through the Log 

Window.
� If the build is not successful, the message 

AutoBuilder failed appears at the bottom of 
the Function Manager. Select the down 
arrow to view the log.

clip

clip
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Figure D3-12     Mirror Assembly 

View the 3-D Model  

 (Preprocessor icons)

a. Click on View Model.
b. At the top of the Preprocessor window, click 

on the Isometric View and Normalize icons to 
adjust the view.

c. Compare your view to Figure D3-12.

� The Preprocessor window opens.
� The 3-D model is displayed. Figure D3-12

Repeat Build and 
View with Clip layer

a. In the Function Manager Solid Model Tab, 
check the box next to Clip Device with Mask 
and verify that the layer name field is set to 
clip.

b. Verify that the Top Cell is still popup.
c. Click on Build Model.
d. Click on Isometric View and Normalize.
e. Compare your view to Figure D3-13.
f. Select File > Quit to close the Preprocessor.
g. In the Designer Setup window, uncheck the 

box next to Clip layer.

� The Clip layer displays the cross-section of 
the deposited and etched layers.

� See “Simulating the Process in the Process 
Editor” on page D4-4  for an explanation of 
how the Process Editor layers map to the 
cross-section you see.

� Always check the Top Cell before building a 
model. If the Setup window is closed and 
reopened, a different Top Cell name may 
appear.

Step 2-e What to do What is accomplished
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Figure D3-13    Clip Layer View 

3.4.5: Review Questions
Why does the cross-section diagram show additional thickness along the walls of the layer steps?

The solid model is an approximation of the way a design is processed in a foundry. When the solid model algo-
rithm builds a conformal layer, it adds a thickness equal to the depth of the layer to each vertical wall. For exam-
ple, in the case of the orange poly2 layer shown in the cross-section, the 1.5� is deposited along all surfaces of 
the model before etch. This results in a slight reduction of the etch opening. An actual circuit has a slope to the 
etch profile and is not a sharp vertical step as shown in the solid model picture. Depending on how the design is 
fabricated and how that slope is controlled, that lip may or may not be there in final silicon. See “Deposit and 
Etch Basics” on page D4-1 for more information on this process.

Why would I want to use the clip capability in a real design?
The clip feature has two major uses. For solid modeling, it provides a way to build a portion of a design so you 
can see only the parts you want extruded into a 3-D model. The clip feature also can be used in a simulation, 
where some modules allow the use of symmetry. When this symmetry feature is enabled, a symmetrical portion 
of the design (such as a quadrant) can be built, allowing the software to run in less time, while still enabling it to 
simulate the characteristics of the complete model.
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3.5: Draw a Heatuator

3.5.1: Objective
Build a heatuator consisting of 11 objects. See page D3-2 for an explanation. 

3.5.2: Specific Skills
� How to select multiple objects
� How to Undo operations
� How to Mirror objects 
� How to Nudge (move) objects
� How to Copy and Paste objects

3.5.3: Procedural Guidelines for Advanced Users
1. Start a new cell.
2. Draw the heatuator using Table D3-2 as a guide. All objects are rectangles.
3. Save the cell as heatuator.

Table D3-2       Heatuator Object Summary      

   

Layer Color Fill Location Description 1st coord. 2nd coord.

poly1 green solid Lower left Anchor pad 0, 0 11, 11

Bottom half Long, thin arm 11, 9 219, 11

anchor1 lightorange none On lower anchor pad Small anchor 4, 4 7, 7

poly1 green solid Upper left Anchor pad 0, 13 11, 24

Upper half Long, thin arm 11, 13 219, 15

anchor1 lightorange none On upper anchor pad Small anchor 4, 17 7, 20

poly1 green solid Upper half Long, thick arm 51, 13 219, 27

Extreme right Vertical arm connection 214, 9 219, 27

dimple red none On thick arm Left dimple 74, 19 77, 22

On thick arm Middle dimple 127, 19 130, 22

On thick arm Right dimple 180, 19 183, 22
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3.5.4: Procedure for New Users 

   

Step 3-a What to do What is accomplished

Start a new cell   Along the top icon row, click on the arrow 
next to New File and select New Cell.

A new unnamed cell is opened.

Build lower anchor 
pad in poly1

a. Select poly1.
b. Select the Rectangle icon.
c. Place coordinates 0, 0 and 11, 11.

� You built a square in the solid green poly1 
layer.

� Repeat Mode should still be on.

Build lower long arm Place coordinates 11, 9 and 219, 11. The arm is also in poly1.

Build lower anchor a. Select anchor1.
b. Place coordinates 4, 4 and 7, 7.
c. Right click to end the Rectangle command.

� The coordinates define the diagonal of the 
rectangle.

Create a mirrored 
copy of the three 
objects   

  (third icon from 
right)

a. Click on one of the three components.
b. Press and hold Shift while you select the 

other two objects.
c. From the lower icon row, next to the Mirror 

icon, click on the arrow. (The Mirror icon is 
third from the right, while the similar-
looking Flip icon is to its left.)

d. Select Mirror Up.

� You can select a single object with the mouse 
without using an icon or menu bar command.

� Select groups with Shift, or Select rectangular 
area from the Select objects vertical icon menu.

� A Mirror Up operation retains the original and 
makes a mirrored copy directly above the 
original’s bounding box.

Nudge the copy up 2 
units     

a. From the lower icon row, to the far right, 
select the Nudge icon.

b. Click twice in the top middle section of the 
canvas.

� The Nudge command moves the selected object 
incrementally by the Working Grid setting 
(which is 1 unit). Multiple nudges work when 
Repeat Mode is on.

� The nudge direction is determined by where 
you click in the drawing area (see“Nudge an 
Object” on page D2-30  for details).

� Following this procedure results in a mirrored 
copy displaced 2 units above the original.

drawn objects

Mirror Up

Nudge
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3.5.5: Review Questions
What if I wanted to build all the poly1 objects as a single polygon?

The entire arm and vertical connect structure can be drawn as a single poly1 polygon. It makes no difference to 
the Layout Editor or to the final mask export file if polygons of the same layer overlap. There are many ways to 
accomplish the same task; pick the technique with which you are most comfortable.

How are dimples used in a MEMS design?
Because you are at only the 2-D level in the design, it is difficult to visualize the 3-D effect of a dimple. The dim-
ple is a protrusion from the sliding arm. When the thermally actuated arm moves, it needs to have enough free-
dom to move with minimal friction effects. After the sacrificial oxide is etched away and the chip is operational, 
the dimples that stick out from the arm allow it to slide easily across the underlying silicon nitride.

Step 3-b What to do What is accomplished

Build long thick arm a. Select poly1.
b. Select the Rectangle icon.
c. Place coordinates 51, 13 and 219, 27.

A long, thick rectangular arm is built on the poly1 
layer.

Build vertical connect Place coordinates 214, 9 and 219, 27. This rectangle connects the previously built 
objects. Overlapping has no effect on the final 
model.

Build dimple a. Select the dimple layer.
b. Place coordinates 74, 19 and 77, 22.
c. Right click to end the Rectangle command.

The dimple acts as a standoff for the sliding 
actuator arm.

Copy and paste 
remaining dimples   

a. Click on the dimple to select it.
b. From the upper horizontal icon row, select 

Copy.
c. Click on the lower left corner of the dimple 

as the FROM point. If this is difficult, click 
when the coordinate readout is at 74, 19.

d. From the upper horizontal icon row, select 
Paste.

e. Place two copies of the dimple at 
coordinates 127, 19 and at 180, 19.

f. Right click to end the Paste mode.

� When copying the dimple, the coordinate you 
used as the FROM point is used as a reference 
coordinate during the paste operation. 

� Three dimples are placed along the thick 
moving arm.

Save your work a. Save the cell as heatuator. 
b. Save the library.

The working cell is now named and all changes to 
the project are saved.
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3.6: Complete the Heatuator Assembly

3.6.1: Objective
Complete the heatuator assembly by adding power connections to the anchor pads and a linkage arm to the assembly.

3.6.2: Specific Skills
� How to set a path width
� How to build a path

3.6.3: Procedural Guidelines for Advanced Users
1. Start a new cell.
2. Add heatuator as a cell reference at origin 0, 0.
3. Add connector as a cell reference at origin -39, 0.
4. Add contact_pad as a cell reference at origin -9, 22.
5. Draw the linkage mechanism in poly1 as a path of width 2. 

Enter coordinates  217, 26   224, 26   224, -8   230, -8   230, -55.
6. Save the cell as heatuator_assy.

Figure D3-14    Heatuator Assembly
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3.6.4: Procedure for New Users 

Step 4 What to do What is accomplished

Start a new cell   Select New Cell from the upper icon row. You are starting a new unnamed cell.

Create a cell 
reference 
(heatuator)

a. From the vertical icon column, select the Reference 
icon.

b. In the dialog window that opens, in the Cell field, 
select heatuator from the cell window.

c. In the Origin field, enter 0, 0.
d. Click on Apply.
e. Zoom to View All.

� This adds the heatuator cell you just built.

� Do not close the window yet.

Create another 
cell reference 
(connector)

a. Place connector as a cell reference at origin -39, 0.
b. Click on Apply.
c. View All to see your work.

� This adds another existing cell to the current 
cell by linking it as a reference. 

� Leave the window open.
� The cell is a connector to a power line.

Create another 
cell reference 
(contact_pad)

a. Place contact_pad as a cell reference at 
origin -9, 22.

b. Click on Apply.
c. Click on Close.
d. Select the View All icon to see the assembly.

The contact pad is another power connector.

Build linkage 
mechanism 
using a path

a. Select poly1.
b. From the menu bar, select Object > Path.
c. In the dialog window, set a width of 2.
d. Click on Apply and Close.
e. From the vertical icon column, select Path.
f. Start the path at coordinate 217, 26 and move right.
g. Click at coordinate 224, 26 and move down.
h. Click at coordinate 224, -8 and move right.
i. Click at coordinate 230, -8 and move down.
j. Click at coordinate 230, -55.
k. Right click to end.

� Using a Path is an easy way to draw a line 
with thickness.

� The new width setting is retained for your 
Layout Editor session.

� The default flush endcap option starts and 
stops the path at the coordinates you enter. 
The other options will extend the path length 
beyond the mouse coordinates.

� The linkage mechanism ends at the origin.

Save your work Save the cell as heatuator_assy. Also save library. The assembly is saved.

Verify the 
design hierarchy

a. Click on the upper horizontal row Cell Browser 
icon.

b. Expand the entries that have + before them.

� The browser shows how your cells are 
organized.

� All cell references are parts of other cells.
� Cells can appear in more than one place.
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3.6.5: Review Questions
Why does the path object have a center line? Can you turn it off?

The center line is a reference line that makes it easier to see the placement of the thick line with respect to the rest 
of the circuitry or shapes. You can turn off this line using the Object Browser. A complete discussion of the 
Object Browser, including how to deal with visibility attributes for paths, can be found in the Reference section 
under “Object Browser” on page D5-68.

What does (Top Cell) mean when placed next to a cell entry in the Cell browser window?
This designation means that the cell is at the top of the cell hierarchy and is not referenced by any other cells. The 
heatuator_assy cell is the current working top cell in the design. Other cells have this designation because they 
haven’t been used yet in the sequence. When a design is completed, there should be only one top cell listing.
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3.7: Create a Heatuator Array

3.7.1: Objective
Create an array of ten heatuator assemblies and connect the array to a set of power rails.

3.7.2: Specific Skills
� How to create an array reference
� How to use the Object Browser
� How to use the Ruler
� How to delete objects
� How to calculate placement based on extents
� How to use Modify > Object to find out more information about an object
� How to mirror a large group of objects horizontally
� How to align one cell structure to another for connectivity

3.7.3: Procedural Guidelines for Advanced Users
1. Create a new cell.
2. Place an Array Reference of heatuator_assy cells: 

a. Set the Array for a 40 unit Row distance (-46 unit Row spacing).
b. Make the Array 1 column wide and 5 rows high.
c. Place the Origin at -1, 0.

3. Create a cell reference using the rails cell. Align anchor2 polygons with an origin of  -39, -10.
4. Mirror Right to create a ten-cell array with full rail connections.
5. Shift the mirrored portion two units to the left so the common poly is lined up.
6. Save the cell as heatuator_array.

Figure D3-15    Heatuator Array
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3.7.4: Procedure for New Users 

Step 5 What to do What is accomplished

Create new cell Select New Cell from the top icon row. A new cell is opened.

Analyze the 
heatuator_assy 
cell   

a. From the vertical icon column, click on the Reference icon.
b. In the dialog window that opens, in the Cell field, enter 

heatuator_assy.
c. Set the Origin to 0, 0.
d. Click on Apply and Close.
e. From the menu bar, select 

View > Object types > Properties...
f. In the Object Browser window that opens (see Figure D3-16), 

click on the + sign next to reference, and check the Visible 
Extents box. It may be helpful to click on the Refresh screen 
icon.

g. From the menu bar, select Other > Ruler and measure the 
height of the outside extents box.

h. Right click to end the Ruler mode.
i. Click on the heatuator_assy structure to select it, and then Cut 

the object with the horizontal menu icon.

� You will find out more about this 
cell before using it in the design.

� The Object Browser allows you to 
view the properties you choose for 
an object.

� Extents are the boundaries of the 
object. The display shows several 
white boxes. No part of the object 
is outside the largest box.

� The height of the box is 86 units.
� You don’t need the single Cell 

Reference for the design.

Create an 
Array 
Reference of 5 
heatuator_array 
cells

a. From the vertical icon column, click on the arrow next to the 
Reference icon, selecting Array Reference. This opens the 
arrayref dialog window, shown in Figure D3-16.

b. In the window next to the Cell field, click on the Browse... 
button and select heatuator_assy. 

c. The desired repeating distance (known as the vertical pitch or 
Row distance) is 40. Therefore, set the Row distance field to 40. 
Note that this setting causes the cells to overlap, but only in the 
linkage mechanism area.

d. Set Columns to 1 and Rows to 5.
e. Set Origin to -1, 0.
f. Apply and Close the window.

� An Array Reference allows you to 
place multiple copies of a cell in an 
X Y matrix.

� The row spacing can be used 
instead. Row spacing is the 
distance between the bottom of one 
cell and the top of the next. The 
formula is Row spacing = Row 
distance - extent height = -46.

� The value is negative because the 
cell boundaries overlap. 

Create a cell 
Reference 
(rails) to 
connect power 
to the array

a. From the vertical icon column, click on the arrow next to the 
Reference icon and select the Reference option.

b. In the window that opens, select the rails cell.
c. Set Origin to an arbitrary value.
d. Apply and Close the window.
e. Use the Edit > Move menubar option to line up the rails cell 

with the heatuator_assy array (see detailed graphics in Figure 
D3-17).
�  If the extents are still visible, the left extent edge of the 

heatuator_assy and that of the rails should be aligned. In 
addition, the anchor2 rectangle edges should also touch. 

�  In the vertical direction, the rails cell should overlap all the 
connector and contact_pad cells of the heatuator_assy cells.

� When you have finished lining up 
the rails, click on Modify > Object 
and check the origin. 

� It should be around -39, -10. 
� The exact vertical position is not 

critical, as long as the rails have 
poly2 fully covering the 
contact_pad contact area.

� For easier visual alignment, try 
changing layer fill patterns 
(see page D2-25 for help).
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Figure D3-16    

Create a copy 
of the entire 
placement  

a. Select all the objects on the canvas: 
�  Click on the arrow next to the Select objects icon.
�  Choose Select rectangular area.
�  Draw a box around the entire assembly to select it.

b. From the horizontal icon menu, select Mirror Right.
c. Nudge or Edit > Move to shift the mirrored portion two units to 

the left. The vertical path poly1 linkage portions of the two 
assemblies should now overlap.

d. Turn off the Visible Extents property.

� The Mirror operation makes a 
mirror image of the selected objects 
and leaves the original in place.

� The mirroring is about the 
bounding box of the array and to 
the right. It needs to be shifted so 
the poly1 sections overlap.

� Ten heatuator assemblies are 
connected by power rails.

Save work Save the cell as heatuator_array. Also save micromirror.cat. The assembly is saved.

Step 5 What to do What is accomplished

Array Reference dialog window Object Browser makes Extents visible
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Figure D3-17    

Array Reference

heatuator_assy showing Extents

Completed heatuator_array cell

Blowup of rails cell. The white circles show the areas where
the heatuator_assy and rails cells should align horizontally. 
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3.8: Connect the Heatuator Array and Mirror

3.8.1: Objective
Place the completed heatuator_array and popup cells, and connect them with poly2.

3.8.2: Specific Skills
� How to place and connect completed assemblies
� How to place at an angle of rotation

3.8.3: Procedural Guidelines for Advanced Users
1. Create a new cell.
2. Create a cell reference using the heatuator_array cell. Rotate 180 degrees and place at 229, -30.
3. Create a cell reference using the popup cell. Place at 0, 120.
4. Connect the poly1 linkage arms of the heatuator array and the long center connector of the popup mirror 

hinge assembly with a new poly1 rectangle. Exact coordinates are -7, 0 and 7, 48.
5. Save the cell as mirror_array.

Figure D3-18    Mirror Array
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3.8.4: Procedure for New Users 

Figure D3-19    Mirror Array

Step 6 What to do What is accomplished

Create a new 
cell

From the top icon row select New Cell. Most of the work in this cell will consist 
of references to other cells

Create a cell 
reference of the 
heatuator_array 
cell

a. From the vertical icon column, click on the Reference icon.
b. In the window that opens, select the heatuator_array cell.
c. Set the Angle at 180 degrees.
d. Set the Origin to 229, -30.
e. Apply and Close the window.

� The array orientation is flipped from 
its original position.

� As an alternative to changing the 
Angle, check Reflect vertically True 
instead.

Create a cell 
Reference of the 
popup mirror 
cell

a. From the vertical icon column, click on the Reference icon.
b. In the window that opens, select the popup cell.
c. Set the Origin to 0, 120.
d. Apply and Close the window.

This is the assembly built in Steps 1 and 
2.

Connect the two 
cell placements

a. Select the Rectangle icon.
b. Connect the poly1 linkage arms of the heatuator array and 

the long center connector of the popup mirror hinge 
assembly.

c. For exact placement, the coordinates are 
-7, 0 and 7, 48.

� The poly1 layer should still be 
selected.

� The assembly is now complete, except 
for the external connections through 
the bond pads.

Save your work Save the cell as mirror_array. Also save micromirror.cat. The assembly is saved.

blow-up of connector
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3.9: Finalizing the Project

3.9.1: Objective
Place the completed mirror_array cell, create a pad frame of bonding pads around the periphery of the layout, and 
connect the bond pads to the power rails of the heatuator assembly.

3.9.2: Specific Skills
� How to place bond pads.
� How to connect power wiring for a device.
� How to adjust the Preprocessor display for clarity.

3.9.3: Procedural Guidelines for Advanced Users
1. Create a new cell.
2. Create a cell reference using the padframe cell. Place at 0, 0.
3. Create a cell reference using the mirror_array cell. Place at 0, -50.
4. Draw connector wires fourteen units thick in poly2 from the power rails to eight of the pad cells. Connect rail 

tops and bottoms to different pads for optimal power distribution.
5. Save the cell as scan_assy.

Figure D3-20    Mirror Array with Padframe
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3.9.4: Procedure for New Users 

Step 7 What to do What to expect

Create new cell From the top icon row, select New Cell. Most of this cell consists of references.

Create 
padframe cell 
reference

a. From the vertical icon column, select the Reference 
icon.

b. In the dialog window that opens, click on the 
Browse button next to Cell, and select padframe.

c. In the Origin field, enter 0, -50.
d. Select Apply and Close.
e. View All to see the entire padframe.

� Twelve pads are used to provide anchors for the 
device.

� A padframe generator can also be used to 
complete this procedure.

Create 
mirror_array 
cell reference

a. From the vertical icon column, click on the 
Reference icon.

b. In the window that opens, select mirror_array.
c. Set the Origin to 0, -50.
d. Apply and Close the window.

This places the components of the assembly in the 
center of the padframe.

Hook up bond 
pads on right 
side

a. Select poly2.
b. Connect the poly2 of the two right side rails to the 

poly2 of the pads:
�  Use a path object of width 14.
�  Connect the top and the bottom of each of the 

rails for a total of four connections.
�  Connect to the nearest bond pad.
�  Four pads are required.

� See page D3-26 for reference on how to set the 
path width.

� Exact placement is not critical.
� It is permissible for the poly2 polygons to 

overlap because they are all the same material.

Mirror your 
work

a. Select all the path polygons just created.
b. From the lower icon row, click on the Mirror icon.
c. Draw a line along the Y-axis and through the origin 

(which is visible as a small circle in the middle of 
the drawing area).

� With this simple procedure, you have mirrored 
the four connectors about the Y origin and 
connected the remaining four pads. See Figure 
D3-20.

� This Mirror command allows you to set the 
mirror axis anywhere you wish.

Save cell Save the cell as scan_assy. Also save library. The assembly is saved.

Build a 3-D 
Model

a. On the Layout tab of the Function Manager, select 
scan_assy as the Top Cell.

b. Click on the Solid Model tab of the Function 
Manager.

c. Be sure the Clip Device with Mask option is 
unchecked.

d. Click on Build Model.

� The 3-D model is built.
� It will take several minutes to finish the build.
� When finished, a window appears with the 

message "Build model finished successfully."
� The Preprocessor opens automatically after a 

successful build.

View the 3-D 
Model

a. Select Edit > Edit Model from the Preprocessor 
menu bar.

b. Increase the Z Scale field value to see the layer 
depth in more detail.

c. Select Part Display in the Edit Model window.
d. Remove some layers by highlighting layers in the 

left column and clicking on the Remove arrow icon. 
to see only the active layers.

e. When finished, from the Preprocessor menu bar, 
select File > Quit.

� The 3-D model is displayed.
� Several views with different Z depth, rotation, 

and visible layers are shown in Figure D3-21.
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   The Preprocessor display can be adjusted for a variety of views:

Figure D3-21    
default view Z axis magnification

substrate layer removed

oxide removed; model rotated

close-up of mirror and heatuator

close-up of mirror: taken after Step 2


